Banner
HomeTOCPrevNextGlossSearchHelp

PDF

Table of Contents

Configuring Cisco 700 Series Routers with a Router Running Cisco IOS Software


Configuring Cisco 700 Series Routers with a Router Running Cisco IOS Software

Configuring Cisco 700 Series Routers with a Router Running Cisco IOS Software

This chapter contains configuration examples for connecting a Cisco 700 series router to a router running Cisco Internetwork Operating System (Cisco IOS) software. In these examples, the remote router is a Cisco 765, and the central site router is a Cisco 4500. However, you can replace the remote Cisco 765 with any Cisco 700 series router, and you can replace the central site Cisco 4500 with a router running Cisco IOS software.


Note In these examples, the Cisco 4500 serial interface being configured is an ISDN Primary Rate Interface (PRI) interface. Depending on the router model being used at the central site network, the serial interface might be a different type.

For configuration examples for connecting a Cisco 700 series router to a CiscoPro CPA900 series router, or to another Cisco 700 series router, refer to the chapter "Configuring a Cisco 700 Series Router with a CiscoPro CPA900 or Cisco 700 Series Router."

This chapter contains the following sections:


IP Static Routing and Callback with CHAP Authentication

This section describes how to configure the the Cisco 765 and the Cisco 4500 routers for Internet Protocol (IP) static routing and callback with Challenge Handshake Authentication Protocol (CHAP).

Figure 5-1 is an illustration of the configuration used in this example.

Figure 5-1 : IP Static Routing and Callback with CHAP Authentication---Example Configuration

fig_1.gif


Central Site Cisco 4500 Command Summary

Following is the command summary for configuring the central site Cisco 4500 for IP static routing and callback with CHAP authentication:


configure terminal
hostname 4500
enable password <password>
username 4500 password 4500
username 765 password 765
isdn switch-type primary-5ess
map-class dialer s3
dialer callback-server username
controller T1 0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Ethernet0
ip address 172.18.124.2 255.255.255.0
no shutdown
interface Serial0:23
description This is pri-5ess 555-3693
ip address 172.16.125.1 255.255.255.0
encapsulation ppp
dialer idle-timeout 360
dialer wait-for-carrier-time 60
dialer map ip 172.16.125.7 name 765 class s3 5553693
dialer-group 1
ppp authentication chap
ppp callback accept
no shutdown
router eigrp 100
redistribute static
network 172.18.124.0
ip host c765 172.16.125.7
ip route 192.168.147.8 255.255.255.248 172.16.125.7
dialer-list 1 protocol ip permit
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
password lab
login
end


Central Site Cisco 4500 Configuration Instructions

Take the following steps to configure the central site Cisco 4500 for IP static routing and callback with CHAP authentication:

Step 1 Use the configure terminal command at the privileged EXEC prompt to enter global configuration mode:


Router# configure terminal

Step 2 Use the hostname command to configure the router with a host name:


Router(config)# hostname 4500

Step 3 Use the enable password command to to assign a password for the privileged command level


4500(config)# enable password <password>

Step 4 Use the username password command to configure the central site Cisco 4500 and the remote Cisco 765 with a username and a password to be used during CHAP authentication:


4500(config)# username 4500 password 4500
4500(config)# username 765 password 765

Step 5 Use the isdn switch-type command to configure the router with the ISDN switch being used:


4500(config)# isdn switch-type primary-5ess

Step 6 Use the map-class command to define quality of service (QOS) parameters associated with a static map:


4500(config)# map-class dialer s3

Step 7 Use the dialer callback-server command to configure the router to make callbacks to the remote Cisco 765:


4500(config)# dialer callback-server username

Step 8 Use the controller command to configure the T1 line:


4500(config)# controller T1 0

Step 9 Use the framing command to configure extended super frame packet encapsulation on the T1 line:


4500(config-if)# framing esf

Step 10 Use the linecode b8zs command to select B8ZS line-code type for the T1 line:


4500(config-if)# linecode b8zs

Step 11 Use the pri-group command to configure the PRI channels for the T1 line:


4500(config-if)# pri-group timeslots 1-24

Step 12 Use the interface command to configure the Ethernet interface:


4500(config-if)# interface Ethernet0

Step 13 Use the ip address command to configure the Ethernet interface with an IP address:


4500(config-if)# ip address 172.18.124.2 255.255.255.0

Step 14 Use the no shutdown command to enable the Ethernet interface:


4500(config-if)# no shutdown

Step 15 Use the interface serial command to configure the PRI B channels:


4500(config-if)# interface Serial0:23

Step 16 Use the description command to add a description of the interface configuration:


4500(config-if)# description This is pri-5ess 555-3693

Step 17 Use the ip address command to configure the interface with an IP address and a subnet mask:


4500(config-if)# ip address 172.16.125.1 255.255.255.0

Step 18 Use the encapsulation command to configure packet framing to PPP:


4500(config-if)# encapsulation ppp

Step 19 Use the dialer idle-timeout command to specify the idle time (in seconds) before the PRI line is disconnected:


4500(config-if)# dialer idle-timeout 360

Step 20 Use the dialer wait-for-carrier-time command to specify how long (in seconds) to wait for the carrier to come up when a call is placed:


4500(config-if)# dialer wait-for-carrier-time 60

Step 21 Use the dialer map command to configure the router to call a remote site based on specific data traffic criteria:


4500(config-if)# dialer map ip 172.16.125.7 name 765 class s3 5553693

Step 22 Use the dialer-group command to configure the number of the dialer access group to which the serial interface belongs:


4500(config-if)# dialer-group 1

Step 23 Use the ppp authentication command to configure the route to perform CHAP authentication:


4500(config-if)# ppp authentication chap

Step 24 Use the ppp callback command to configure the router to accept Point-to-Point Protocol (PPP) callbacks:


4500(config-if)# ppp callback accept

Step 25 Use the no shutdown command to enable the serial interface:


4500(config-if)# no shutdown

Step 26 Use the router eigrp command to configure the router for Enhanced Interior Gateway Routing Protocol (Enhanced IGRP) routing:


4500(config-if)# router eigrp 100

Step 27 Use the redistribute command to redistribute static routes from one routing domain to another:


4500(config)# redistribute static

Step 28 Use the network command to specify the list of networks for IGRP routing:


4500(config)# network 172.18.124.0

Step 29 Use the ip host command to define a static host name-to-address mapping in the host cache:


4500(config)# ip host c765 172.16.125.7

Step 30 Use the ip route command to to configure a static route to the remote router:


4500(config)# ip route 192.168.147.8 255.255.255.248 172.16.125.7

Step 31 Use the dialer-list protocol command to define a dialer list to control dialing by protocol:


4500(config)# dialer-list 1 protocol ip permit

Step 32 Use the line command to configure the console terminal line:


4500(config)# line con 0

Step 33 Use the exec-timeout command to set the interval that the EXEC command interpreter waits until user input is detected:


4500(config)# exec-timeout 0 0

Step 34 Use the line command to configure the auxiliary EIA/TIA-232 DTE port:


4500(config)# line aux 0

Step 35 Use the transport input command to define the protocols to use to connect to a specific line of the router:


4500(config)# transport input all

Step 36 Use the line command to specify a virtual terminal for remote console access:


4500(config)# line vty 0 4

Step 37 Use the password command to configure a password on the virtual terminal line:


4500(config)# password lab

Step 38 Use the login command to enable password checking at login:


4500(config)# login

Step 39 Use the end command to exit configuration mode for the router:


4500(config)# end


Remote Cisco 765 Command Summary

Following is the command summary for configuring the remote Cisco 765 for IP static routing and callback with CHAP authentication:

set system 765        
set switch 5ess
set multidestination on
cd lan
set ip address 192.168.147.9 
set ip netmask 255.255.255.248 
set ip routing on
set ip rip update periodic
cd
set user 4500
set ip address 172.16.125.7 
set ip netmask 255.255.255.0
set ip routing on
set ip framing none
set encapsulation ppp 
set ppp callback request always
set ip route destination 0.0.0.0 ga 172.16.125.1 propagate on
set number 5558011 
set bridging off
set timeout 360
set ppp secret host
cd
set ppp authentication incoming chap
set ppp authentication outgoing chap
set ppp secret client
reboot


Remote Cisco 765 Configuration Instructions

Take the following steps to configure the remote Cisco 765 for IP static routing and callback with CHAP authentication:

Step 1 Use the set system command to configure the router with a system name:


> set system 765

Step 2 Use the set switch command to configure the ISDN BRI switch type being used:


765> set switch 5ess

Step 3 Use the set multidestination command to enable the router to dial out to multiple destinations:


765> set multidestination on

Step 4 Use the change user command to configure the LAN profile:


765> cd lan

Step 5 Use the set ip address command to configure the local LAN interface with an IP address:


765:Lan> set ip address 192.168.147.9

Step 6 Use the set ip netmask command to configure the local LAN interface with a subnet mask:


765:Lan> set ip netmask 255.255.255.248

Step 7 Use the set ip routing command to enable IP routing on the local Ethernet LAN:


765:Lan> set ip routing on

Step 8 Use the set ip rip update command to configure Routing Information Protocol (RIP) updates to be sent onto the local Ethernet LAN every 30 seconds:


765:Lan> set ip rip update periodic

Step 9 Use the change user command to exit configuration mode for the LAN profile:


765:Lan> cd

Step 10 Use the set user command to create a profile for the central site Cisco 4500:


765> set user 4500

Step 11 Use the set ip address command to configure the ISDN interface to the central site Cisco 4500 with an IP address:


765:4500> set ip address 172.16.125.7

Step 12 Use the set ip netmask command to configure the ISDN interface to the central site Cisco 4500 with an IP address:


765:4500> set ip netmask 255.255.255.0

Step 13 Use the set ip routing command to enable IP routing to the central site Cisco 4500:


765:4500> set ip routing on

Step 14 Use the set ip framing command to configure IP packets sent to the central site Cisco 4500 for Internet Protocol Control Protocol (IPCP) framing:


765:4500> set ip framing none

Step 15 Use the set encapsulation command to configure PPP packet encapsulation for packets sent to the central site Cisco 4500:


765:4500> set encapsulation ppp

Step 16 Use the set ppp callback request command to configure the router to request callbacks from the central site Cisco 4500:


765:4500> set ppp callback request always

Step 17 Use the set ip route destination command to configure an IP static route to the central site Cisco 4500:


765:4500> set ip route destination 0.0.0.0 ga 172.16.125.1
propagate on

Step 18 Use the set number command to enter the ISDN number the router calls to connect to the central site Cisco 4500:


765:4500> set number 5558011

Step 19 Use the set bridging command to disable bridging to the central site Cisco 4500:


765:4500> set bridging off

Step 20 Use the set timeout command to configure the ISDN line to disconnect after 360 seconds of idle time:


765:4500> set timeout 360

Step 21 Use the set ppp secret command to configure the host secret that will be used during CHAP authentication:


765:4500> set ppp secret host
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 22 Use the change user command to configure the system level:


765:4500> cd

Step 23 Use the set ppp authentication command to configure CHAP authentication for both incoming and outgoing calls:


765> set ppp authentication incoming chap
765> set ppp authentication outgoing chap

Step 24 Use the set ppp secret command to configure the client secret that will be used during CHAP authentication:


765> set ppp secret client
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 25 Use the reboot command to reset the router and enable your configuration changes:


765> reboot


IP Static Routing with CHAP Authentication and MLP

This section describes how to configure the central site Cisco 4500 and the remote Cisco 765 for IP static routing with Challenge Handshake Authentication Protocol (CHAP) and Multilink Protocol (MLP).

Figure 5-2 is an illustration of the configuration used in this example.

Figure 5-2 : IP Static Routing with CHAP Authentication and MLP---Example Configuration

fig_2.gif


Central Site Cisco 4500 Command Summary

Following is the command summary for configuring the central site Cisco 4500 for IP static routing with CHAP and MLP:

configure terminal        
hostname 4500
enable password lab
username 4500 password 4500
username 765 password 765

isdn switch-type primary-5ess
controller T1 0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Ethernet0
ip address 172.18.124.2 255.255.255.0
no shutdown
interface Serial0:23
description This is pri-5ess 555-3693
ip address 172.16.125.1 255.255.255.0
encapsulation ppp
dialer idle-timeout 360
dialer wait-for-carrier-time 60
dialer map ip 172.16.125.7 name 765 5553693
dialer-group 1
ppp authentication chap
ppp multilink
dialer load 125
no shutdown
router eigrp 100
redistribute static
network 172.18.124.0
ip host c765 172.16.125.7
ip host c7000 172.18.124.1
ip route 192.168.147.8 255.255.255.248 172.16.125.7
dialer-list 1 protocol ip permit
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
password lab
login
end


Central Site Cisco 4500 Configuration Instructions

Take the following steps to configure the central site Cisco 4500 for IP static routing with CHAP authentication and MLP:

Step 1 Use the configure terminal command at the privileged EXEC prompt to enter the global configuration mode:


router# configure terminal

Step 2 Use the hostname command to configure the router with a host name:


router(config)# hostname 4500

Step 3 Use the enable password command to assign a password for the privileged command level:


4500(config)# enable password <password>

Step 4 Use the username password command to configure the central site Cisco 4500 and the remote Cisco 765 with a username and a password to be used during CHAP authentication:


4500(config)# username 4500 password 4500
4500(config)# username 765 password 765

Step 5 Use the isdn switch-type command to configure the router with the ISDN switch being used:


4500(config)# isdn switch-type primary-5ess

Step 6 Use the controller command to configure the T1 line:


4500(config)# controller T1 0

Step 7 Use the framing command to configure extended super frame packet encapsulation on the T1 line:


4500(config-if)# framing esf

Step 8 Use the linecode b8zs command to select B8ZS line-code type for the T1 line:


4500(config-if)# linecode b8zs

Step 9 Use the pri-group command to configure the PRI channels for the T1 line:


4500(config-if)# pri-group timeslots 1-24

Step 10 Use the interface command to configure the Ethernet interface:


4500(config-if)# interface Ethernet0

Step 11 Use the ip address command to configure the Ethernet interface with an IP address:


4500(config-if)# ip address 172.18.124.2 255.255.255.0

Step 12 Use the no shutdown command to enable the Ethernet interface:


4500(config-if)# no shutdown

Step 13 Use the interface serial command to configure the PRI B channels:


4500(config-if)# interface Serial0:23

Step 14 Use the description command to add a description of the interface configuration:


4500(config-if)# description This is pri-5ess 555-3693

Step 15 Use the ip address command to configure the interface with an IP address and a subnet mask:


4500(config-if)# ip address 172.16.125.1 255.255.255.0

Step 16 Use the encapsulation command to configure packet framing to PPP:


4500(config-if)# encapsulation ppp

Step 17 Use the dialer idle-timeout command to specify the idle time (in seconds) before the PRI line is disconnected:


4500(config-if)# dialer idle-timeout 360

Step 18 Use the dialer wait-for-carrier-time command to specify how long (in seconds) to wait for the carrier to come up when a call is placed:


4500(config-if)# dialer wait-for-carrier-time 60

Step 19 Use the dialer map command to configure the router to call a remote site based on specific data traffic criteria:


4500(config-if)# dialer map ip 172.16.125.7 name 765 5553693

Step 20 Use the dialer-group command to configure the number of the dialer access group to which the serial interface belongs:


4500(config-if)# dialer-group 1

Step 21 Use the ppp authentication command to configure the route to perform CHAP authentication:


4500(config-if)# ppp authentication chap

Step 22 Use the ppp multilink command to configure the router to send data for the same destination over multiple B channels:


4500(config-if)# ppp multilink

Step 23 Use the dialer load command to configure the maximum load before the the dialer places another call to a destination:


4500(config-if)# dialer load 125

Step 24 Use the no shutdown command to enable the serial interface:


4500(config-if)# no shutdown

Step 25 Use the router eigrp command to configure the router for Enhanced Interior Gateway Routing Protocol (Enhanced IGRP) routing:


4500(config)# router eigrp 100

Step 26 Use the redistribute command to redistribute static routes from one routing domain to another:


4500(config)# redistribute static

Step 27 Use the network command to specify the list of networks for IGRP routing:


4500(config)# network 172.18.124.0

Step 28 Use the ip host command to define a static host name-to-address mapping in the host cache:


4500(config)# ip host c765 172.16.125.7
4500(config)# ip host c7000 172.18.124.1

Step 29 Use the ip route command to to configure a static route to the remote router:


4500(config)# ip route 192.168.147.8 255.255.255.248 172.16.125.7

Step 30 Use the dialer-list protocol command to define a dialer list to control dialing by protocol:


4500(config)# dialer-list 1 protocol ip permit

Step 31 Use the line command to configure the console terminal line:


4500(config)# line con 0

Step 32 Use the exec-timeout command to set the interval that the EXEC command interpreter waits until user input is detected:


4500(config)# exec-timeout 0 0

Step 33 Use the line command to configure the auxiliary EIA/TIA-232 DTE port:


4500(config)# line aux 0

Step 34 Use the transport input command to define the protocols to use to connect to a specific line of the router:


4500(config)# transport input all

Step 35 Use the line command to specify a virtual terminal for remote console access:


4500(config)# line vty 0 4

Step 36 Use the password command to configure a password on the virtual terminal line:


4500(config)# password lab

Step 37 Use the login command to enable password checking at login:


4500(config)# login

Step 38 Use the end command to exit configuration mode for the router:


4500(config)# end


Remote Cisco 765 Command Summary

Following is the command summary to configure the remote Cisco 765 for IP static routing with CHAP and MLP:

set system 765        
set switch 5ess
set multidestination on
set ppp multilink on
cd lan
set ip address 192.168.147.9 
set ip netmask 255.255.255.248 
set ip routing on
set ip rip update periodic
cd
set user 4500
set ip address 172.16.125.7 
set ip netmask 255.255.255.0
set ip routing on
set ip framing none
set encapsulation ppp 
set ip route destination 0.0.0.0 ga 172.16.125.1 propagate on
set number 5558011 
set bridging off
set ppp secret host
set timeout 360
demand 2 threshold 32 duration 5
cd 
set ppp authentication incoming chap
set ppp authentication outgoing chap
set ppp secret client
reboot


Remote Cisco 765 Configuration Instructions

Take the following steps to configure the remote Cisco 765 for IP static routing with CHAP authentication and MLP:

Step 1 Use the set system command to configure the router with a system name:


> set system 765

Step 2 Use the set switch command to configure the router for the ISDN BRI switch being used:


765> set switch 5ess

Step 3 Use the set multidestination command to enable the router to dial to multiple remote destinations:


765> set multidestination on

Step 4 Use the set ppp multilink command to enable data to be sent over multiple B channels:


765> set ppp multilink on

Step 5 Use the change user command to configure the LAN profile:


765> cd lan

Step 6 Use the set ip address command to configure the local Ethernet LAN interface with an IP address:


765:Lan> set ip address 192.168.147.9

Step 7 Use the set ip netmask command to configure the local Ethernet LAN interface with a subnet mask:


765:Lan> set ip netmask 255.255.255.248

Step 8 Use the set ip routing command to enable IP routing on the local Ethernet LAN:


765:Lan> set ip routing on

Step 9 Use the set ip rip update command to configure RIP updates to be sent onto the local Ethernet LAN every 30 seconds:


765:Lan> set ip rip update periodic

Step 10 Use the change user command to exit configuration mode for the LAN profile:


765:Lan> cd

Step 11 Use the set user command to create a profile for the central site Cisco 4500:


765> set user 4500

Step 12 Use the set ip address command to configure the the IP address of the ISDN interface to the central site Cisco 4500:


765:4500> set ip address 172.16.125.7

Step 13 Use the set ip netmask command to configure the subnet mask of the ISDN interface to the central site Cisco 4500:


765:4500> set ip netmask 255.255.255.0

Step 14 Use the set ip routing command to enable IP routing to the central site Cisco 4500:


765:4500> set ip routing on

Step 15 Use the set ip framing command to configure IP packets sent to the central site Cisco 4500 for IPCP framing:


765:4500> set ip framing none

Step 16 Use the set encapsulation command to configure packets sent to the central site Cisco 4500 for PPP packet encapsulation:


765:4500> set encapsulation ppp

Step 17 Use the set ip route destination command to configure a static route to the central site Cisco 4500:


765:4500> set ip route destination 0.0.0.0 ga 172.16.125.1
propagate on

Step 18 Use the set number command to enter the ISDN telephone number the router calls to connect to the central site Cisco 4500:


765:4500> set number 5558011

Step 19 Use the set bridging command to disable bridging to the central site Cisco 4500:


765:4500> set bridging off

Step 20 Use the set ppp secret command to configure the host secret that will be used during CHAP authentication:


765:4500> set ppp secret host
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 21 Use the set timeout command to configure the ISDN line to disconnect after 360 seconds of idle time:


765:4500> set timeout 360

Step 22 Use the demand command to configure when an on-demand ISDN call is made:


765:4500> demand 2 threshold 32 duration 5

Step 23 Use the change user command to configure the system level:


765:4500> cd

Step 24 Use the set ppp authentication command to configure CHAP authentication for both incoming and outgoing calls:


765> set ppp authentication incoming chap
765> set ppp authentication outgoing chap

Step 25 Use the set ppp secret command to configure the client secret that will be used during CHAP authentication:


765> set ppp secret client
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 26 Use the reboot command to reset the router and enable your configuration changes:


765> reboot


IP Static Routing with PAP Authentication

This section describes how to configure the central site Cisco 4500 and the remote Cisco 765 for Internet Protocol (IP) static routing with Password Authentication Protocol (PAP) authentication.

Figure 5-3 is an illustration of the configuration used in this example.

Figure 5-3 : IP Static Routing with PAP Authentication---Example Configuration

s4768.gif


Central Site Cisco 4500 Command Summary

Following is the command summary for configuring the central site Cisco 4500 for IP static routing with PAP authentication:

configure terminal        
hostname 4500
enable password lab
username 4500 password 4500 
username 765 password 765
isdn switch-type primary-5ess
controller T1 0 
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Ethernet0
ip address 172.18.124.2 255.255.255.0
no shutdown
interface Serial0:23
description This is pri-5ess 555-3693
ip address 172.16.125.1 255.255.255.0

encapsulation ppp
dialer idle-timeout 360
dialer wait-for-carrier-time 60
dialer map ip 172.16.125.7 name 765 5553693
dialer-group 1
ppp authentication pap
no shutdown
router eigrp 100
redistribute static
network 172.18.124.0
ip host c765 172.16.125.7
ip route 192.168.147.8 255.255.255.248 172.16.125.7
dialer-list 1 protocol ip permit
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
password lab
login
end


Central Site Cisco 4500 Configuration Instructions

Take the following steps to configure the central site Cisco 4500 for IP static routing with PAP:

Step 1 Use the configure terminal command at the privileged EXEC prompt to enter global configuration mode:


router# configure terminal

Step 2 Use the hostname command to configure the router with a host name:


router(config)# hostname 4500

Step 3 Use the enable password command to to assign a password for the privileged command level:


4500(config)# enable password lab

Step 4 Use the username password command to configure the central site Cisco 4500 and the remote Cisco 765 with a username and a password to be used during CHAP authentication:


4500(config)# username 4500 password 4500
4500(config)# username 765 password 765

Step 5 Use the isdn switch-type command to configure the router with the ISDN switch being used:


4500(config)# isdn switch-type primary-5ess

Step 6 Use the controller command to configure the T1 line:


4500(config)# controller T1 0

Step 7 Use the framing command to configure extended super frame packet encapsulation on the T1 line:


4500(config-if)# framing esf

Step 8 Use the linecode b8zs command to select B8ZS line-code type for the T1 line:


4500(config-if)# linecode b8zs

Step 9 Use the pri-group command to configure the PRI channels for the T1 line:


4500(config-if)# pri-group timeslots 1-24

Step 10 Use the interface command to configure the Ethernet interface:


4500(config-if)# interface Ethernet0

Step 11 Use the ip address command to configure the Ethernet interface with an IP address:


4500(config-if)# ip address 172.18.124.2 255.255.255.0

Step 12 Use the no shutdown command to enable the Ethernet interface:


4500(config-if)# no shutdown

Step 13 Use the interface serial command to configure the PRI B channels:


4500(config-if)# interface Serial0:23

Step 14 Use the description command to add a description of the interface configuration:


4500(config-if)# description This is pri-5ess 555-3693

Step 15 Use the ip address command to configure the interface with an IP address and a subnet mask:


4500(config-if)# ip address 172.16.125.1 255.255.255.0

Step 16 Use the encapsulation command to configure packet framing to PPP:


4500(config-if)# encapsulation ppp

Step 17 Use the dialer idle-timeout command to specify the idle time (in seconds) before the PRI line is disconnected:


4500(config-if)# dialer idle-timeout 360

Step 18 Use the dialer wait-for-carrier-time command to specify how long (in seconds) to wait for the carrier to come up when a call is placed:


4500(config-if)# dialer wait-for-carrier-time 60

Step 19 Use the dialer map command to configure the router to call a remote site based on specific data traffic criteria:


4500(config-if)# dialer map ip 172.16.125.7 name 765 5553693

Step 20 Use the dialer-group command to configure the number of the dialer access group to which the serial interface belongs:


4500(config-if)# dialer-group 1

Step 21 Use the ppp authentication command to configure the route to perform PAP authentication:


4500(config-if)# ppp authentication pap

Step 22 Use the no shutdown command to enable the serial interface:


4500(config-if)# no shutdown

Step 23 Use the router eigrp command to configure the router for Enhanced Interior Gateway Routing Protocol (Enhanced IGRP) routing:


4500(config)# router eigrp 100

Step 24 Use the redistribute command to redistribute static routes from one routing domain to another:


4500(config)# redistribute static

Step 25 Use the network command to specify the list of networks for IGRP routing:


4500(config)# network 172.18.124.0

Step 26 Use the ip host command to define a static host name-to-address mapping in the host cache:


4500(config)# ip host c765 172.16.125.7

Step 27 Use the ip route command to configure a static route to the remote router:


4500(config)# ip route 192.168.147.8 255.255.255.248 172.16.125.7

Step 28 Use the dialer-list protocol command to define a dialer list to control dialing by protocol:


4500(config)# dialer-list 1 protocol ip permit

Step 29 Use the line command to configure the console terminal line:


4500(config)# line con 0

Step 30 Use the exec-timeout command to set the interval that the EXEC command interpreter waits until user input is detected:


4500(config)# exec-timeout 0 0

Step 31 Use the line command to configure the auxiliary EIA/TIA-232 DTE port:


4500(config)# line aux 0

Step 32 Use the transport input command to define the protocols to use to connect to a specific line of the router:


4500(config)# transport input all

Step 33 Use the line command to specify a virtual terminal for remote console access:


4500(config)# line vty 0 4

Step 34 Use the password command to configure a password on the virtual terminal line:


4500(config)# password lab

Step 35 Use the login command to enable password checking at login:


4500(config)# login

Step 36 Use the end command to exit configuration mode for the router:


4500(config)# end


Remote Cisco 765 Command Summary

Following is the command summary to configure the remote Cisco 765 for IP static routing with PAP authentication:

set system 765        
set switch 5ess
set multidestination on
cd lan
set ip address 192.168.147.9 
set ip netmask 255.255.255.248 
set ip routing on
set ip rip update periodic
cd
set user 4500
set ip address 172.16.125.7 
set ip netmask 255.255.255.0
set ip routing on
set ip framing none
set encapsulation ppp
set ip route destination 0.0.0.0 ga 172.16.125.1 propagate on
set number 5558011
set bridging off
set ppp password host
set timeout 360
cd
set ppp authentication in pap
set ppp authentication out pap

set ppp password client
reboot


Remote Cisco 765 Configuration Instructions

Take the following steps to configure the remote Cisco 765 for IP static routing with PAP authentication:

Step 1 Use the set system command to configure the router with a system name:


> set system 765

Step 2 Use the set switch command to configure the router for the ISDN BRI switch being used:


765> set switch 5ess

Step 3 Use the set multidestination command to enable the router to dial to multiple remote destinations:


765> set multidestination on

Step 4 Use the change user command to configure the LAN profile:


765> cd lan

Step 5 Use the set ip address command to configure the IP address of the local Ethernet LAN interface:


765:Lan> set ip address 192.168.147.9

Step 6 Use the set ip netmask command to configure the subnet mask of the local Ethernet LAN interface:


765:Lan> set ip netmask 255.255.255.248

Step 7 Use the set ip routing command to enable IP routing on the local Ethernet LAN:


765:Lan> set ip routing on

Step 8 Use the set ip rip update command to configure RIP updates to be sent onto the local Ethernet LAN every 30 seconds:


765:Lan> set ip rip update periodic

Step 9 Use the change user command to exit configuration mode for the LAN profile:


765:Lan> cd

Step 10 Use the set user command to create a profile for the central site Cisco 4500:


765> set user 4500

Step 11 Use the set ip address command to configure the the IP address of the ISDN interface to the central site Cisco 4500:


765:4500> set ip address 172.16.125.7

Step 12 Use the set ip netmask command to configure the subnet mask of the ISDN interface to the central site Cisco 4500:


765:4500> set ip netmask 255.255.255.0

Step 13 Use the set ip routing command to enable IP routing to the central site Cisco 4500:


765:4500> set ip routing on

Step 14 Use the set ip framing command to configure IP packets sent to the central site Cisco 4500 for IPCP framing:


765:4500> set ip framing none

Step 15 Use the set encapsulation command to configure packets sent to the central site Cisco 4500 for PPP packet encapsulation:


765:4500> set encapsulation ppp

Step 16 Use the set ip route destination command to configure a static route to the central site Cisco 4500:


765:4500> set ip route destination 0.0.0.0 ga 172.16.125.1
propagate on

Step 17 Use the set number command to enter the ISDN number the router calls to connect to the central site Cisco 4500:


765:4500> set number 5558011

Step 18 Use the set bridging command to disable bridging to the central site Cisco 4500:


765:4500> set bridging off

Step 19 Use the set ppp secret command to configure the host secret that will be used during PAP authentication:


765:4500> set ppp password host
Enter new Password: <password>
Re-Type new Password: <password>

The characters will not be echoed on your computer terminal when you enter the PPP password.

Step 20 Use the set timeout command to configure the ISDN line to disconnect after 360 seconds of idle time:


765:4500> set timeout 360

Step 21 Use the change user command to configure the system level:


765:4500> cd

Step 22 Use the set ppp authentication command to configure PAP authentication for both incoming and outgoing calls:


765> set ppp authentication incoming pap
765> set ppp authentication outgoing pap

Step 23 Use the set ppp password command to configure the client secret that will be used during PAP authentication:


765> set ppp password client
Enter new Password: <password>
Re-Type new Password: <password>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 24 Use the reboot command to reset the router and enable your configuration changes:


765> reboot


IP Unnumbered Routing and CHAP Authentication with MLP

This section describes how to configure the central site Cisco 4500 and the remote Cisco 765 for Internet Protocol (IP) unnumbered routing with Challenge Handshake Authentication Protocol (CHAP) authentication and Multilink Protocol (MLP).

Figure 5-4 is an illustration of the configuration used in this example.

Figure 5-4 : IP Unnumbered Routing and CHAP Authentication with MLP---Example Configuration

s4769.gif


Central Site Cisco 4500 Command Summary

Following is the command summary for configuring the central site Cisco 4500 for IP unnumbered routing with CHAP authentication and MLP:

configure terminal        
hostname 4500
enable password lab

username 4500 password 4500
username 765 password 765
isdn switch-type primary-5ess
controller T1 0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Ethernet0
ip address 172.18.124.2 255.255.255.0
no shutdown
interface Serial0:23
description This is pri-5ess 555-3693
ip unnumbered ethernet0 
encapsulation ppp
dialer idle-timeout 360
dialer wait-for-carrier-time 60
dialer map ip 192.168.147.9 name 765 5553693
dialer-group 1
ppp authentication chap
ppp multilink
dialer load 125
no shutdown
router eigrp 100
redistribute static
network 172.18.124.0
ip host c765 192.168.147.9
ip route 192.168.147.8 255.255.255.248 192.168.147.9
ip route 192.168.147.9 255.255.255.255 s0:23
dialer-list 1 protocol ip permit
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
password lab
login
end


Central Site Cisco 4500 Configuration Instructions

Take the following steps to configure the central site Cisco 4500 for IP unnumbered routing with CHAP authentication and MLP:

Step 1 Use the configure terminal command at the privileged EXEC prompt to enter global configuration mode:


router# configure terminal

Step 2 Use the hostname command to configure the router with a host name:


router(config)# hostname 4500

Step 3 Use the enable password command to to assign a password for the privileged command level:


4500(config)# enable password lab

Step 4 Use the username password command to configure the central site Cisco 4500 and the remote Cisco 765 with a username and a password to be used during CHAP authentication:


4500(config)# username 4500 password 4500
4500(config)# username 765 password 765

Step 5 Use the isdn switch-type command to configure the router with the ISDN switch being used:


4500(config)# isdn switch-type primary-5ess

Step 6 Use the controller command to configure the T1 line:


4500(config)# controller T1 0

Step 7 Use the framing command to configure extended super frame packet encapsulation on the T1 line:


4500(config-if)# framing esf

Step 8 Use the linecode b8zs command to select B8ZS line-code type for the T1 line:


4500(config-if)# linecode b8zs

Step 9 Use the pri-group command to configure the PRI channels for the T1 line:


4500(config-if)# pri-group timeslots 1-24

Step 10 Use the interface command to configure the Ethernet interface:


4500(config-if)# interface Ethernet0

Step 11 Use the ip address command to configure the Ethernet interface with an IP address:


4500(config-if)# ip address 172.18.124.2 255.255.255.0

Step 12 Use the no shutdown command to enable the Ethernet interface:


4500(config-if)# no shutdown

Step 13 Use the interface serial command to configure the PRI B channels:


4500(config-if)# interface Serial0:23

Step 14 Use the description command to add a description of the interface configuration:


4500(config-if)# description This is pri-5ess 555-3693

Step 15 Use the ip unnumbered command to enable IP unnumbered routing on the PRI interface using the IP address of the Ethernet interface:


4500(config-if)# ip unnumbered ethernet0

Step 16 Use the encapsulation command to configure packet framing to PPP:


4500(config-if)# encapsulation ppp

Step 17 Use the dialer idle-timeout command to specify the idle time (in seconds) before the PRI line is disconnected:


4500(config-if)# dialer idle-timeout 360

Step 18 Use the dialer wait-for-carrier-time command to specify how long (in seconds) to wait for the carrier to come up when a call is placed:


4500(config-if)# dialer wait-for-carrier-time 60

Step 19 Use the dialer map command to configure the router to call a remote site based on specific data traffic criteria:


4500(config-if)# dialer map ip 192.168.147.9 name 765 5553693

Step 20 Use the dialer-group command to configure the number of the dialer access group to which the serial interface belongs:


4500(config-if)# dialer-group 1

Step 21 Use the ppp authentication command to configure the route to perform CHAP authentication:


4500(config-if)# ppp authentication chap

Step 22 Use the ppp multilink command to configure the router to send data for the same destination over multiple B channels:


4500(config-if)# ppp multilink

Step 23 Use the dialer load command to configure the maximum load before the router places an ISDN call:


4500(config-if)# dialer load 125

Step 24 Use the no shutdown command to enable the PRI interface:


4500(config-if)# no shutdown

Step 25 Use the router eigrp command to configure the router for Enhanced Interior Gateway Routing Protocol (Enhanced IGRP) routing:


4500(config)# router eigrp 100

Step 26 Use the redistribute command to redistribute static routes from one routing domain to another:


4500(config)# redistribute static

Step 27 Use the network command to specify the list of networks for IGRP routing:


4500(config)# network 172.18.124.0

Step 28 Use the ip host command to define a static host name-to-address mapping in the host cache:


4500(config)# ip host c765 192.168.147.9

Step 29 Use the ip route command to configure a static route to the remote router:


4500(config)# ip route 192.168.147.8 255.255.255.248 192.168.147.

The following part of the ip route is required only when using a Cisco 750 series router with a software release prior to 3.1(4).

4500(config)# ip route 192.168.147.9 255.255.255.255 s0:23


Note In this configuration, you cannot perform the ping command or Telnet from the Cisco 700 series router. However, traffic will pass when using a Cisco 750 series router with a software release prior to 3.1(4.4).

Step 30 Use the dialer-list protocol command to define a dialer list to control dialing by protocol:


4500(config)# dialer-list 1 protocol ip permit

Step 31 Use the line command to configure the console terminal line:


4500(config)# line con 0

Step 32 Use the exec-timeout command to set the interval that the EXEC command interpreter waits until user input is detected:


4500(config)# exec-timeout 0 0

Step 33 Use the line command to configure the auxiliary EIA/TIA-232 DTE port:


4500(config)# line aux 0

Step 34 Use the transport input command to define the protocols to use to connect to a specific line of the router:


4500(config)# transport input all

Step 35 Use the line command to specify a virtual terminal for remote console access:


4500(config)# line vty 0 4

Step 36 Use the password command to configure a password on the virtual terminal line:


4500(config)# password lab

Step 37 Use the login command to enable password checking at login:


4500(config)# login

Step 38 Use the end command to exit configuration mode for the router:


4500(config)# end


Remote Cisco 765 Command Summary

Following is the command summary for configuring the remote Cisco 765 for IP unnumbered routing with CHAP authentication and MLP:


set system 765
set switch 5ess
set multidestination on
set ppp multilink on
cd lan
set ip address 192.168.147.9
set ip netmask 255.255.255.248
set ip routing on
set ip rip update periodic
cd
set user 4500
set ip routing on
set ip framing none
set encapsulation ppp
set ip route destination 0.0.0.0 ga 0.0.0.0
set number 5558011
set bridging off
set ppp secret host
set timeout 360
demand 2 threshold 32 duration 5
cd
set ppp authentication incoming chap
set ppp authentication outgoing chap
set ppp secret client
reboot


Remote Cisco 765 Configuration Instructions

Take the following steps to configure the remote Cisco 765 for IP unnumbered routing with CHAP authentication and MLP:

Step 1 Use the set system command to configure the router with a system name:


> set system 765

Step 2 Use the set switch command to configure the router for the ISDN BRI switch being used:


765> set switch 5ess

Step 3 Use the set multidestination command to enable the router to dial to multiple remote destinations:


765> set multidestination on

Step 4 Use the set ppp multilink command to enable data to be sent over multiple B channels:


765> set ppp multilink on

Step 5 Use the change user command to configure the LAN profile:


765> cd lan

Step 6 Use the set ip address command to configure the IP address of the local Ethernet LAN interface:


765:Lan> set ip address 192.168.147.9

Step 7 Use the set ip netmask command to configure the subnet mask of the local Ethernet LAN interface:


765:Lan> set ip netmask 255.255.255.248

Step 8 Use the set ip routing command to enable IP routing on the local Ethernet LAN:


765:Lan> set ip routing on

Step 9 Use the set ip rip update command to configure RIP updates to be sent onto the local Ethernet LAN every 30 seconds:


765:Lan> set ip rip update periodic

Step 10 Use the change user command to exit configuration mode for the LAN profile:


765:Lan> cd

Step 11 Use the set user command to create a profile for the central site Cisco 4500:


765> set user 4500

Step 12 Use the set ip routing command to enable IP routing to the central site Cisco 4500:


765:4500> set ip routing on

Step 13 Use the set ip framing command to configure IP packets sent to the central site Cisco 4500 for IPCP framing:


765:4500> set ip framing none

Step 14 Use the set encapsulation command to configure packets sent to the central site Cisco 4500 for PPP packet encapsulation:


765:4500> set encapsulation ppp

Step 15 Use the set ip route destination command to configure an unnumbered route to the central site Cisco 4500:


765:4500> set ip route destination 0.0.0.0 ga 0.0.0.0

Step 16 Use the set number command to enter the ISDN number the router calls to connect to the central site Cisco 4500:


765:4500> set number 5558011

Step 17 Use the set bridging command to disable bridging to the central site Cisco 4500:


765:4500> set bridging off

Step 18 Use the set ppp secret command to configure the host secret that will be used during CHAP authentication:


765:4500> set ppp secret host
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 19 Use the set timeout command to configure the ISDN line to disconnect after 360 seconds of idle time:


765:4500> set timeout 360

Step 20 Use the demand command to configure when an on-demand ISDN call is made:


765:4500> demand 2 threshold 32 duration 5

Step 21 Use the change user command to configure the system level:


765:4500> cd

Step 22 Use the set ppp authentication command to configure CHAP authentication for both incoming and outgoing calls:


765> set ppp authentication incoming chap
765> set ppp authentication outgoing chap

Step 23 Use the set ppp secret command to configure the client secret that will be used during CHAP authentication:


765> set ppp secret client
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 24 Use the reboot command to reset the router and enable your configuration changes:


765> reboot


IP Static and IPX Static Routing with PPP

This section describes how to configure the central site Cisco 4500 and Cisco 765 for Internet Protocol (IP) static and Internetwork Packet Exchange (IPX) static routing with Point-to-Point Protocol (PPP).

Figure 5-5 is an illustration of the configuration used in this example.

Figure 5-5 : IP Static and IPX Static Routing with PPP---Example Configuration

s4770.gif


Central Site Cisco 4500 Command Summary

Following is the command summary to configure the central site Cisco 4500 for IP static and IPX static routing with PPP:

configure terminal        
hostname 4500
enable password lab
username 4500 password 4500

username 765 password 765
ipx routing
isdn switch-type primary-5ess
controller T1 0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Ethernet0
ip address 172.18.124.2 255.255.255.0
ipx network 48124 encapsulation sap
no mop enabled
no shutdown
interface Serial0:23
description This is pri-5ess 555-3693
ipx network 32125
ip address 172.16.125.1 255.255.255.0
no ipx route-cache
ipx watchdog-spoof 
encapsulation ppp
ppp multilink
ppp authentication chap
dialer idle-timeout 360
dialer wait-for-carrier-time 60
dialer map ipx 32125.0040.f902.cf5d name 765 5553693
dialer map ip 172.16.125.7 name 765 5553693
dialer-group 1
no shutdown
ipx route 1478 32125.0040.f902.cf5d
ipx router rip
no network 32125
redistribute static
router eigrp 100
redistribute static
network 172.18.124.0
ip host c765 172.16.125.7
ip route 192.168.147.8 255.255.255.248 172.16.125.7
dialer-list 1 protocol ipx permit
dialer-list 1 protocol ip permit
end


Central Site Cisco 4500 Configuration Instructions

Take the following steps to configure the central site Cisco 4500 for IP static and IPX static routing with PPP:

Step 1 Use the configure terminal command at the privileged EXEC prompt to enter global configuration mode:


router# configure terminal

Step 2 Use the hostname command to configure the router with a host name:


router(config)# hostname 4500

Step 3 Use the enable password command to to assign a password for the privileged command level:


4500(config)# enable password lab

Step 4 Use the username password command to configure the central site Cisco 4500 and the remote Cisco 765 with a username and a password to be used during CHAP authentication:


4500(config)# username 4500 password 4500
4500(config)# username 765 password 765

Step 5 Use the ipx routing command to enable IPX routing:


4500(config)# ipx routing

Step 6 Use the isdn switch-type command to configure the router with the ISDN switch being used:


4500(config)# isdn switch-type primary-5ess

Step 7 Use the controller command to configure the T1 line:


4500(config)# controller T1 0

Step 8 Use the framing command to configure extended super frame packet encapsulation on the T1 line:


4500(config-if)# framing esf

Step 9 Use the linecode b8zs command to select B8ZS line-code type for the T1 line:


4500(config-if)# linecode b8zs

Step 10 Use the pri-group command to configure the PRI channels for the T1 line:


4500(config-if)# pri-group timeslots 1-24

Step 11 Use the interface command to configure the Ethernet interface:


4500(config-if)# interface Ethernet0

Step 12 Use the ip address command to configure the Ethernet interface with an IP address:


4500(config-if)# ip address 172.18.124.2 255.255.255.0

Step 13 Use the ipx network command to enable IPX routing on the Ethernet interface, configure the Ethernet interface with an IPX network number, and to configure the Ethernet interface for Novell's Ethernet 802.3 packet encapsulation:


4500(config-if)# ipx network 48124 encapsulation sap

Step 14 Use the no mop enabled command to disable Maintenance Operation Protocol (MOP) on the Ethernet interface:


4500(config-if)# no mop enabled

Step 15 Use the no shutdown command to enable the Ethernet interface:


4500(config-if)# no shutdown

Step 16 Use the interface serial command to configure the PRI B channels:


4500(config-if)# interface Serial0:23

Step 17 Use the description command to add a description of the interface configuration:


4500(config-if)# description This is pri-5ess 555-3693

Step 18 Use the ipx network command to enable IPX routing on the PRI interface and to configure the PRI interface with an IPX network number:


4500(config-if)# ipx network 32125

Step 19 Use the ip address command to configure the PRI interface with an IP address and a subnet mask:


4500(config-if)# ip address 172.16.125.1 255.255.255.0

Step 20 Use the no ipx route-cache command to enable IPX fast switching and autonomous switching on the PRI interface:


4500(config-if)# no ipx route-cache

Step 21 Use the ipx watchdog-spoof command to have the router respond to the local server's watchdog packets on behalf of the remote workstation:


4500(config-if)# ipx watchdog-spoof

Step 22 Use the encapsulation command to configure packet framing to PPP:


4500(config-if)# encapsulation ppp

Step 23 Use the ppp multilink command to configure the router to send data for the same destination over multiple B channels:


4500(config-if)# ppp multilink

Step 24 Use the ppp authentication command to configure the route to perform CHAP authentication:


4500(config-if)# ppp authentication chap

Step 25 Use the dialer idle-timeout command to specify the idle time (in seconds) before the PRI line is disconnected:


4500(config-if)# dialer idle-timeout 360

Step 26 Use the dialer wait-for-carrier-time command to specify how long (in seconds) to wait for the carrier to come up when a call is placed:


4500(config-if)# dialer wait-for-carrier-time 60

Step 27 Use the dialer map command to configure the router to call a remote site based on specific data traffic criteria:


4500(config-if)# dialer map ipx 32125.0040.f902.cf5d name 765 5553693
4500(config-if)# dialer map ip 172.16.125.7 name 765 5553693

Step 28 Use the dialer-group command to configure the number of the dialer access group to which the serial interface belongs:


4500(config-if)# dialer-group 1

Step 29 Use the no shutdown command to enable the PRI interface:


4500(config-if)# no shutdown

Step 30 Use the ipx route command to add a static IPX route to the routing table:


4500(config)# ipx route 1478 32125.0040.f902.cf5d

Step 31 Use the ipx router command to enable IPX RIP routing protocol:


4500(config)# ipx router rip

Step 32 Use the no network command to remove a specific network from the IGRP routing process:


4500(config)# no network 32125

Step 33 Use the router igrp command to configure the router for Interior Gateway Routing Protocol (IGRP) routing:


4500(config)# router eigrp 100

Step 34 Use the redistribute command to redistribute static routes from one routing domain to another:


4500(config)# redistribute static

Step 35 Use the network command to specify the list of networks for IGRP routing:


4500(config)# network 172.18.124.0

Step 36 Use the ip host command to define a static host name-to-address mapping in the host cache:


4500(config)# ip host c765 172.16.125.7

Step 37 Use the ip route command to configure a static route to the remote router:


4500(config)# ip route 192.168.147.8 255.255.255.248 172.16.125.7

Step 38 Use the dialer-list protocol command to define a dialer list to control dialing by protocol:


4500(config)# dialer-list 1 protocol ipx permit
4500(config)# dialer-list 1 protocol ip permit

Step 39 Use the end command to exit configuration mode for the router:


4500(config)# end


Remote Cisco 765 Command Summary

Following is the command summary to configure the remote Cisco 765 for IP static and IPX static routing with PPP:

set system 765        
set switch
set multidestination on
cd lan
set ipx network 1478
set ipx framing 802.2
set ipx routing on
set ipx rip update periodic
set ip address 192.168.147.9
set ip netmask 255.255.255.248
set ip routing on
set ip rip update periodic
cd
set user 4500
set ipx network 32125
set ipx routing on
set ipx route destination 3039e670 gateway 32125:0c08af65
set ipx service name CORP_FS1 type 4 address 3039e670:01:0451
set ipx spoof 10
set ipx rip update off
set ipx framing none
set ip address 172.16.125.7
set ip netmask 255.255.255.0
set ip routing on
set ip framing none
set encapsulation ppp
set ip route destination 0.0.0.0 ga 172.16.125.1 propagate on
set number 5558011
set bridging off

set timeout 360
set ppp secret host
cd
set ppp authentication incoming chap
set ppp authentication outgoing chap
set ppp secret client
reboot


Remote Cisco 765 Configuration Instructions

Take the following steps to configure the remote Cisco 765 for IP static and IPX static routing with PPP:

Step 1 Use the set system command to configure the router with a system name:


> set system 765

Step 2 Use the set switch command to configure the router for the ISDN BRI switch being used:


765> set switch

Step 3 Use the set multidestination command to enable the router to dial to multiple remote destinations:


765> set multidestination on

Step 4 Use the change user command to configure the LAN profile:


765> cd lan

Step 5 Use the set ipx network command to configure the IPX network number for the local Ethernet LAN interface:


765:Lan> set ipx network 1478

Step 6 Use the set ipx framing command to configure IPX packets sent onto the local Ethernet LAN for IEEE 802.3 framing:


765:Lan> set ipx framing 802.2

Step 7 Use the set ipx routing command to enable IPX routing on the Ethernet LAN:


765:Lan> set ipx routing on

Step 8 Use the set ipx rip update command to configure IPX RIP packets to be sent onto the Ethernet LAN every 60 seconds:


765:Lan> set ipx rip update periodic

Step 9 Use the set ip address command to configure the IP address of the local Ethernet LAN interface:


765:Lan> set ip address 192.168.147.9

Step 10 Use the set ip netmask command to configure the subnet mask of the local Ethernet LAN interface:


765:Lan> set ip netmask 255.255.255.248

Step 11 Use the set ip routing command to enable IP routing on the Ethernet LAN:


765:Lan> set ip routing on

Step 12 Use the set ip rip update command to configure IP RIP packets to be sent onto the Ethernet LAN every 30 seconds:


765:Lan> set ip rip update periodic

Step 13 Use the change user command to configure the system level:


765:Lan> cd

Step 14 Use the set user command to create a user profile for the central site Cisco 4500:


765> set user 4500

Step 15 Use the set ipx network command to configure the network number for the ISDN interface to the central site Cisco 4500:


765:4500> set ipx network 32125

Step 16 Use the set ipx routing command to enable IPX routing to the central site Cisco 4500:


765:4500> set ipx routing on

Step 17 Use the set ipx route command to configure an IPX static route to the central site Cisco 4500:


765:4500> set ipx route destination 3039e670 gateway 32125:0c08af65

Step 18 Use the set ipx service command to configure an IPX static route to a central site Novell file server:


765:4500> set ipx service name CORP_FS1 type 4 address
3039e670:01:0451

Step 19 Use the set ipx spoof command to configure the Cisco 765 to respond to the local server's watchdog packets on behalf of the remote workstation:


765:4500> set ipx spoof 10

Step 20 Use the set ipx rip update command to prevent IPX RIP packets from being sent to the central site Cisco 4500:


765:4500> set ipx rip update off

Step 21 Use the set ipx framing command to configure IPX packets sent to the central site Cisco 4500 for Internetwork Packet Exchange Control Protocol (IPXCP) framing:


765:4500> set ipx framing none

Step 22 Use the set ip address command to configure the IP address of the ISDN interface to the central site Cisco 4500:


765:4500> set ip address 172.16.125.7

Step 23 Use the set ip netmask to configure the subnet mask of the ISDN interface to the central site Cisco 4500:


765:4500> set ip netmask 255.255.255.0

Step 24 Use the set ip routing command to enable IP routing to the central site Cisco 4500:


765:4500> set ip routing on

Step 25 Use the set ip framing to configure IP packets sent to the central site Cisco 4500 for IPCP framing:


765:4500> set ip framing none

Step 26 Use the set encapsulation command to configure PPP packet encapsulation for packets sent to the central site Cisco 4500:


765:4500> set encapsulation ppp

Step 27 Use the set ip route command to configure an IP static route to the central site Cisco 4500:


765:4500> set ip route destination 0.0.0.0 gateway 172.16.125.1
propagate on

Step 28 Use the set number command to configure the ISDN telephone number the router will dial to connect to the central site Cisco 4500:


765:4500> set number 5558011

Step 29 Use the set bridging command to disable bridging to the central site Cisco 4500:


765:4500> set bridging off

Step 30 Use the set timeout command to configure the ISDN line to disconnect after 360 seconds of no line activity:


765:4500> set timeout 360

Step 31 Use the set ppp secret command to configure the host secret that will be used during CHAP authentication:


765:4500> set ppp secret host
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 32 Use the change user command to configure the system level:


765:4500> cd

Step 33 Use the set ppp authentication command to configure CHAP authentication for both incoming and outgoing calls:


765> set ppp authentication incoming chap
765> set ppp authentication outgoing chap

Step 34 Use the set ppp secret command to configure the client secret that will be used during CHAP authentication:


765> set ppp secret client
Enter new Password: <secret>
Re-Type new Password: <secret>

The characters will not be echoed on your computer terminal when you enter the PPP secret.

Step 35 Use the reboot command to reset the router and enable your configuration changes:


765> reboot


IPX Static Routing with PPP

This section describes how to configure the remote Cisco 765 and the central site Cisco 4500 for Internetwork Packet Exchange (IPX) static routing with Point-to-Point Protocol (PPP).

Figure 5-6 is an illustration of the configuration used in this example.

Figure 5-6 : IPX Static Routing with PPP---Example Configuration

s4771.gif


Central Site Cisco 4500 Command Summary

Following is the command summary for configuring the central site Cisco 4500 for IPX static routing with PPP:

configure terminal        
hostname 4500
enable password lab
username 765 
no ip routing
ipx routing
isdn switch-type primary-5ess
controller T1 0
framing esf
linecode b8zs
pri-group timeslots 1-24
interface Ethernet0
ipx network 23160 encapsulation sap
no mop enabled
no shutdown
interface Serial0:23
description This is pri-5ess 555-3693

no ipx route-cache
ipx watchdog-spoof 
encapsulation ppp
ppp multilink
dialer idle-timeout 360
dialer wait-for-carrier-time 60
dialer map ipx 32125.0040.f902.cf5d name 765 5553693
dialer-group 1
ipx network 32125
no shutdown
ipx route 1478 32125.0040.f902.cf5d
ipx router rip
no network 32125
redistribute static
dialer-list 1 protocol ipx permit
end


Central Site Cisco 4500 Configuration Instructions

Take the following steps to configure the central site Cisco 4500 for IPX static routing with PPP:

Step 1 Use the configure terminal command at the privileged EXEC prompt to enter global configuration mode:


router# configure terminal

Step 2 Use the hostname command to configure the router with a host name:


router(config)# hostname 4500

Step 3 Use the enable password command to assign a password for the privileged command level:


4500(config)# enable password lab

Step 4 Use the username command to configure the router's user ID:


4500(config)# username 765

Step 5 Use the no ip routing command to disable IP routing to the remote Cisco 765:


4500(config)# no ip routing

Step 6 Use the ipx routing command to enable IPX routing to the remote Cisco 765:


4500(config)# ipx routing

Step 7 Use the isdn switch-type command to configure the router with the ISDN switch being used:


4500(config)# isdn switch-type primary-5ess

Step 8 Use the controller command to configure the T1 line:


4500(config)# controller T1 0

Step 9 Use the framing command to configure extended super-frame packet-encapsulation on the T1 line:


4500(config-if)# framing esf

Step 10 Use the linecode b8zs command to select B8ZS line-code type for the T1 line:


4500(config-if)# linecode b8zs

Step 11 Use the pri-group command to configure the PRI channels for the T1 line:


4500(config-if)# pri-group timeslots 1-24

Step 12 Use the interface command to configure the Ethernet interface:


4500(config-if)# interface Ethernet0

Step 13 Use the ipx network command to enable IPX routing on the Ethernet interface, configure the Ethernet interface with an IPX network number, and to configure the Ethernet interface for Novell's Ethernet 802.3 packet encapsulation:


4500(config-if)# ipx network 23160 encapsulation sap

Step 14 Use the no mop enabled command to disable Maintenance Operation Protocol (MOP) on the Ethernet interface:


4500(config-if)# no mop enabled

Step 15 Use the no shutdown command to enable the Ethernet interface:


4500(config-if)# no shutdown

Step 16 Use the interface serial command to configure the PRI B channels:


4500(config-if)# interface Serial0:23

Step 17 Use the description command to add a description of the interface configuration:


4500(config-if)# description This is pri-5ess 555-3693

Step 18 Use the no ipx route-cache command to enable IPX fast switching and autonomous switching on the PRI interface:


4500(config-if)# no ipx route-cache

Step 19 Use the ipx watchdog-spoof command to have the router respond to the local server's watchdog packets on behalf of the remote workstation:


4500(config-if)# ipx watchdog-spoof

Step 20 Use the encapsulation command to configure packet framing to PPP:


4500(config-if)# encapsulation ppp

Step 21 Use the ppp multilink command to configure the router to send data for the same destination over multiple B channels:


4500(config-if)# ppp multilink

Step 22 Use the dialer idle-timeout command to to specify the idle time (in seconds) before the PRI line is disconnected:


4500(config-if)# dialer idle-timeout 360

Step 23 Use the dialer wait-for-carrier-time command to specify how long (in seconds) to wait for the carrier to come up when a call is placed:


4500(config-if)# dialer wait-for-carrier-time 60

Step 24 Use the dialer map command to configure the router to call a remote site based on specific data traffic criteria:


4500(config-if)# dialer map ipx 32125.0040.f902.cf5d name 765 5553693

Step 25 Use the dialer-group command to configure the number of the dialer access group to which the serial interface belongs:


4500(config-if)# dialer-group 1

Step 26 Use the ipx network command to enable IPX routing on the PRI interface and to configure the PRI interface with an IPX network number:


4500(config-if)# ipx network 32125

Step 27 Use the no shutdown command to enable the PRI interface:


4500(config-if)# no shutdown

Step 28 Use the ipx route command to add a static IPX route to the routing table:


4500(config)# ipx route 1478 32125.0040.f902.cf5d

Step 29 Use the ipx router command to enable IPX RIP routing protocol:


4500(config)# ipx router rip

Step 30 Use the no network command to remove a specific network from the IGRP routing process:


4500(config)# no network 32125

Step 31 Use the redistribute command to redistribute static routes from one routing domain to another:


4500(config)# redistribute static

Step 32 Use the dialer-list protocol command to define a dialer list to control dialing by protocol:


4500(config)# dialer-list 1 protocol ipx permit

Step 33 Use the end command to exit configuration mode for the router:


4500(config)# end


Remote Cisco 765 Command Summary

Following is the command summary for configuring the remote Cisco 765 for IPX static routing with PPP:

set system 765        
set switch
set multidestination on
cd lan
set ipx network 1478
set ipx framing 802.2
set ipx routing on
set ipx rip update periodic
cd
set user 4500
set ipx network 32125
set ipx routing on
set ipx route destination 3039e670 gateway 32125:0c08af65
set ipx service name CORP_FS1 type 4 address 3039e670:01:0451
set ipx spoofing 10
set ipx rip update off
set ipx framing none
set encapsulation ppp
set number 5558011
set bridging off
set timeout 360
reboot


Remote Cisco 765 Configuration Instructions

Take the following steps to configure the remote Cisco 765 for IPX static routing with PPP:

Step 1 Use the set system command to configure the router with a system name:


> set system 765

Step 2 Use the set switch command to configure the router for the ISDN BRI switch being used:


765> set switch

Step 3 Use the set multidestination command to enable the router to dial to multiple remote destinations:


765> set multidestination on

Step 4 Use the change user command to configure the LAN profile:


765> cd lan

Step 5 Use the set ipx network command to configure the IPX network number for the local Ethernet LAN interface:


765:Lan> set ipx network 1478

Step 6 Use the set ipx framing command to configure packets sent onto the local Ethernet LAN for IEEE 802.3 framing:


765:Lan> set ipx framing 802.2

Step 7 Use the set ipx routing command to enable IPX routing on the local Ethernet LAN:


765:Lan> set ipx routing on

Step 8 Use the set ipx rip update command to configure IPX RIP packets to be sent onto the Ethernet LAN every 60 seconds:


765:Lan> set ipx rip update periodic

Step 9 Use the change user command to exit configuration mode for the LAN profile:


765:Lan> cd

Step 10 Use the set user command to create a user profile for the central site Cisco 4500:


765> set user 4500

Step 11 Use the set ipx network command to configure the network number for the ISDN interface to the central site Cisco 4500:


765:4500> set ipx network 32125

Step 12 Use the set ipx routing command to enable IPX routing to the central site Cisco 4500:


765:4500> set ipx routing on

Step 13 Use the set ipx route command to configure a static IPX route to the central site Cisco 4500:


765:4500> set ipx route destination 3039e670 gateway 32125:0c08af65

Step 14 Use the set ipx service command to configure a static route to the central site Novell file server:


765:4500> set ipx service name CORP_FS1 type 4 address
3039e670:01:0451

Step 15 Use the set ipx spoof command to have the remote Cisco 765 respond to the local server's watchdog packets on behalf of the remote workstation:


765:4500> set ipx spoofing 10

Step 16 Use the set ipx rip update command to prevent IPX RIP packets from being sent to the central site Cisco 4500:


765:4500> set ipx rip update off

Step 17 Use the set ipx framing command to configure IPX packets sent to the central site Cisco 4500 for IPXCP framing:


765:4500> set ipx framing none

Step 18 Use the set encapsulation command to configure PPP packet encapsulation for packets sent to the central site Cisco 4500:


765:4500> set encapsulation ppp

Step 19 Use the set number command to configure the ISDN telephone number the router will dial to connect to the central site Cisco 4500:


765:4500> set number 5558011

Step 20 Use the set bridging command to disable bridging to the central site Cisco 4500:


765:4500> set bridging off

Step 21 Use the set timeout command to configure the ISDN line to disconnect after 360 seconds of no line activity:


765:4500> set timeout 360

Step 22 Use the reboot command to reset the router and enable your configuration changes:


765:4500> reboot

HomeTOCPrevNextGlossSearchHelp
-

Copyright 1988-1996 © Cisco Systems Inc.